Huawei Mate 10 Pro has “OK Google” voice issue for some users

By | 25th May 2018

Huawei Mate 10 Pro owners have been experiencing issues with the “OK Google” voice activation for Google Assistant. A user first reported the problem in the Google Product forums on April 30, though some people say they have been experiencing it for months.

According to the original poster, the bug means that some of the Voice options are greyed in the settings menu, meaning the “OK Google” hotphrase used to launch Google Assistant doesn’t work. Dozens of users say they have the same issue.

A screenshot of the Voice options menu on the Huawei Mate 10 Pro. Google Product Forums

Both Huawei and Google support members have at acknowledged the problem, but a fix is still to be rolled out.

In a message said to have been pulled from a Huawei HiCare live chat, a Huawei support agent apparently said:

Editor's Pick

“[The issue] is caused by incompatibilities between Google Play services V12.6.73 and Huawei phones. Huawei and Google have come up with the solution. Please stay tuned for version updates of Google Play services.

If accurate, this wouldn’t be the first time Huawei products haven’t played nice with Google Play Services: only a week ago, we reported on multiple Huawei devices seeing “Google Play Services are updating” errors.

We can’t offer much in the way of a solution for now, and we don’t know when one may arrive, but we have reached out to Huawei and Google on the matter and will update this article should we receive a response.

Thanks, Mark Porter.